strace log::SurfaceFlinger

After successfully porting the m5-rc14 last week, i just curious why is it not as stable as m3. Then i try to port the m5-rc15. I was interested to this just because of curious whether pppd is running or not. I have tried to make such ppp connection to USB modem with m3, but the problem seems to be trapped inside stubs.c or stub.c. Forget it, it’s just closed now by Google. My assumption is just, probably in the new sdk i will get ppp running and can make some call or at least able to browse the internet using ppp. Failed with rc14 -i just don’t get why i can’t get stable console. It’s just like switched between /system/bin/sh and /bin/sh, which i copied from OSELAS. So i remove the /bin and edit the environment vars.

The problem still remain. I just get this from the strace log. weird :

18:13:13 writev(5, [{"\4", 1}, {"ServiceManager", 15}, {"ServiceManager: unable to find service SurfaceFlinger\n", 55}], 3) = 71
18:13:13 writev(5, [{"\4", 1}, {"runtime", 8}, {"Still waiting for surface flinger...", 37}], 3) = 46
18:13:13 writev(5, [{"\4", 1}, {"ServiceManager", 15}, {"ServiceManager: waiting for service SurfaceFlinger\n", 52}], 3) = 68
18:13:13 clock_gettime(CLOCK_MONOTONIC, {472, 72299030}) = 0
18:13:13 clock_gettime(CLOCK_MONOTONIC, {472, 72533292}) = 0
18:13:13 clock_gettime(CLOCK_MONOTONIC, {472, 72804040}) = 0
18:13:13 futex(0x12574, FUTEX_WAIT, 0, {4, 999000000}) = -1 ETIMEDOUT (Connection timed out)

So, I just got, application error : com.android.googleaps, An error has occured in com.google.android.googleaps. Unable to create service blah blah blah.

I tried to googling and found that this error usually appear when you just use new emulator and not give -wipe-data when run the new emulator. Okay. i just point my assumption that my hardware is just like the emulator and there’s a memory remain to write data from the old SDK. Do i have to format the file system ? So i decide to flash the fresh and brand new file system.

I do the same procedures just like the first m5-rc14 porting, not use the rc15. I expect getting something new, but again it just shows me the same error.